Click here to Skip to main content
15,665,444 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Every time I run npm create-react-app my-app or any npm command in gitbash console I get this error:
npm ERR! BC0D0000:error:1C800066:Provider routines:ossl_gcm_stream_update:cipher operation failed:c:\ws\deps\openssl\openssl\providers\implementations\ciphers\ciphercommon_gcm.c:320:
npm ERR!

What I have tried:

I tried many solutions I found in the web, from reinstalling node js, installing the new openssl version, reinstalling git bash (console), allowed gitbash and nodejs through firewall, running this command
npm config set strict-ssl false
and even formatted the whole PC.
Updated 13-Apr-23 6:40am

1 solution

I just installed the latest LTS Node version and It works for me.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900