Click here to Skip to main content
15,845,367 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi all,

I am going to submit an Azure support ticket; however, in the interests of saving time, I've instead wanted to first try Google search and asking questions on Code Project and Stack Overflow.

I am using an azure db and SSMS. It does not seem to matter which version of SSMS i am using; they all seem to fail equally.

Here is the SSMS 2014 connection dialog box[^]

So, I open SSMS 2014 on Windows 7 Professional x64. Both Windows and SSMS have all the latest updates installed. I connect to my Azure DB using the credentials shown (I've masked the login info for obvious reasons).

Then I get connected and I open up a DB. It does not matter which db I use it seems to fail equally on anything. I then expand the Tables folder and right click the menu commands that Design, Edit Top 200 Rows, or Select Top 1000 Rows, or do any of the Script Table As etc.

This shows an example of what I am right-clicking.[^]

The new Query window opens with the SELECT Top 1000 command, and then I get a crash, as shown:

Here is the crash screen[^]

Why is this happening? Do I need to install a patch or something? Has anyone else experienced this?

What I have tried:

Google searching, searching Stack Overflow.
Richard MacCutchan 2-Jun-16 11:10am    
Your links require a userid and password.
Brian C Hart 2-Jun-16 11:13am    
Hi Richard,

Thanks for reminding me. I've gone onto my server and opened up the permissions. The links to the images should now work.

Brian Hart
Richard Deeming 2-Jun-16 11:31am    
That sounds like a bug that needs to be reported to Microsoft.

Have you tried with the 2016 version of SSMS? It's apparently free to use now, even if you don't have a SQL 2016 licence:[^]

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900