Click here to Skip to main content
15,886,026 members
Please Sign up or sign in to vote.
1.00/5 (2 votes)
See more:
Hello everyone, I write this code, but I cannot explain where is the Problem here, that output cases not match.

Given a string, S, of length N that is indexed from 0 to N - 1, print its even-indexed and odd-indexed characters as 2 space-separated strings on a single line (see the Sample below for more detail).

Note: 0 is considered to be an even index.

Example
S = adbecf

Print abc def

Input Format

The first line contains an integer, T (the number of test cases).
Each line i of the T subsequent lines contain a string, S .


Output Format

For each String S[j] (where 0 <= j <= T - 1 ), print j even-indexed characters, followed by a space, followed by j odd-indexed characters.

Sample Input:
2
Hacker
Rank

Sample Output:
Hce akr
Rn ak

And my code is:
using System;
using System.Collections.Generic;
using System.IO;
class Solution
{
    static void Main(String[] args)
    {
        /* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution */
        int t = int.Parse(Console.ReadLine());

        for (int i = 0; i < t ; i++)
        {
            string input = Console.ReadLine();
            
            for (int j = 0; j < input.Length; j+=2)
            {
                var currChar = input[j];

                Console.Write(currChar);

            }
            Console.Write(" ");
            for (int k = 1; k < input.Length; k+=2)
            {
                var currChar = input[k];
                Console.Write(currChar);


            }
            Console.WriteLine();


        }
       


    }
}


What I have tried:

Write a code in C# from the Task, but in output cases does not maches.
Posted
Updated 18-Jan-22 2:51am
Comments
Chris Copeland 18-Jan-22 4:25am    
Just out of curiosity, what isn't working in the above? I pasted this code into .NET Fiddle and, aside from having to change the Solution class to public, it was working exactly as intended?
Richard Deeming 18-Jan-22 4:33am    
"For each String S[j] (where 0 <= j <= T - 1 ), print j even-indexed characters, followed by a space, followed by j odd-indexed characters."

Your sample output doesn't match that. You first string j = 0 is printing 3 even/odd characters, but according to the instructions it should be printing 0 even/odd characters.

Either you've mistyped your assignment, or there's a mistake in the assignment.

Compiling does not mean your code is right! :laugh:
Think of the development process as writing an email: compiling successfully means that you wrote the email in the right language - English, rather than German for example - not that the email contained the message you wanted to send.

So now you enter the second stage of development (in reality it's the fourth or fifth, but you'll come to the earlier stages later): Testing and Debugging.

Start by looking at what it does do, and how that differs from what you wanted. This is important, because it give you information as to why it's doing it. For example, if a program is intended to let the user enter a number and it doubles it and prints the answer, then if the input / output was like this:
Input   Expected output    Actual output
  1            2                 1
  2            4                 4
  3            6                 9
  4            8                16
Then it's fairly obvious that the problem is with the bit which doubles it - it's not adding itself to itself, or multiplying it by 2, it's multiplying it by itself and returning the square of the input.
So with that, you can look at the code and it's obvious that it's somewhere here:
C#
private int Double(int value)
   {
   return value * value;
   }

Once you have an idea what might be going wrong, start using the debugger to find out why. Put a breakpoint on the first line of the method, and run your app. When it reaches the breakpoint, the debugger will stop, and hand control over to you. You can now run your code line-by-line (called "single stepping") and look at (or even change) variable contents as necessary (heck, you can even change the code and try again if you need to).
Think about what each line in the code should do before you execute it, and compare that to what it actually did when you use the "Step over" button to execute each line in turn. Did it do what you expect? If so, move on to the next line.
If not, why not? How does it differ?
Hopefully, that should help you locate which part of that code has a problem, and what the problem is.
This is a skill, and it's one which is well worth developing as it helps you in the real world as well as in development. And like all skills, it only improves by use!
 
Share this answer
 
Comments
Georgiev Tihomir 18-Jan-22 4:27am    
Thanx!
OriginalGriff 18-Jan-22 4:38am    
You're welcome!
Quote:
Write a code in C# from the Task, but in output cases does not maches.

You forgot to tell us the actual output. Tell what output is not, is no help to us, telling what output is, can help us to understand what is going on.

Your code do not behave the way you expect, or you don't understand why !

There is an almost universal solution: Run your code on debugger step by step, inspect variables.
The debugger is here to show you what your code is doing and your task is to compare with what it should do.
There is no magic in the debugger, it don't know what your code is supposed to do, it don't find bugs, it just help you to by showing you what is going on. When the code don't do what is expected, you are close to a bug.
To see what your code is doing: Just set a breakpoint and see your code performing, the debugger allow you to execute lines 1 by 1 and to inspect variables as it execute.

Debugger - Wikipedia, the free encyclopedia[^]

Mastering Debugging in Visual Studio 2010 - A Beginner's Guide[^]
Basic Debugging with Visual Studio 2010 - YouTube[^]

Debugging C# Code in Visual Studio - YouTube[^]

The debugger is here to only show you what your code is doing and your task is to compare with what it should do.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900