Click here to Skip to main content
15,747,111 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Hello and Thanks,

i have a bug by installing:

failed to register layer: ApplyLayer exit status 1 stdout: stderr: unlinkat /usr/lib/python3/dist-packages/zipp-1.0.0.egg-info: invalid argument

Can anyone help me ? I got the error in debian (aktual version) and in docker (aktual version).

I run it in a proxmox ct.


What I have tried:

upgrade, test in Debian and in Ubuntu.
Updated 22-May-23 21:44pm
Richard Deeming 22-May-23 3:44am    
Nobody can help you fix a problem that you can't describe clearly.

An error message without any context is useless.

Start by specifying precisely what commands you are using, and providing the details of any modifications you have made to the docker image files.
AlexanderPlaza 25-May-23 10:50am    
I am not the original poster but I am running into the same issue.

The background is:
Proxmox hypervisor running on SSD ZFS (Mirrored) running it within a lxc container.
Installed docker using these steps:

The steps I took that caused this error to come up: just running the command
<user>@<machine_name_redacted>:~/codeprojectai# docker pull codeproject/ai-server
Using default tag: latest
latest: Pulling from codeproject/ai-server
dbf6a9befcde: Pull complete
a1d1e86cfdb1: Pull complete
8f6d664c962b: Pull complete
fd7c5b4f10e4: Pull complete
0071e09cb41a: Pull complete
de21b5475ce0: Pull complete
28979bba0e98: Pull complete
c80ff7e123b7: Pull complete
b119dbbc1dbb: Pull complete
759f7c739f4c: Pull complete
610f8f1036d2: Pull complete
dfdd17077f0c: Pull complete
99fb4bec90f6: Pull complete
89bb3693ca44: Pull complete
ca824218a3d3: Pull complete
4f4fb700ef54: Pull complete
29b18b2bd75d: Pull complete
5f2d04a0ff4f: Extracting 447.4MB/447.4MB
393e73764825: Download complete
4a1106c5bb30: Download complete
3d4463eba850: Download complete
9e114a71b696: Download complete
a4a6a59b50f4: Download complete
c87581796408: Download complete
failed to register layer: unlinkat /usr/lib/python3/dist-packages/zipp-1.0.0.egg-info: invalid argument

Running a docker info provides:

Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 24.0.1
Storage Driver: overlay2
Backing Filesystem: zfs
Supports d_type: true
Using metacopy: false
Native Overlay Diff: false
userxattr: true
Logging Driver: json-file
Cgroup Driver: systemd
Cgroup Version: 2
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: io.containerd.runc.v2 runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 3dce8eb055cbb6872793272b4f20ed16117344f8
runc version: v1.1.7-0-g860f061
init version: de40ad0
Security Options:
Profile: builtin
Kernel Version: 5.15.107-2-pve
Operating System: Ubuntu 22.04.2 LTS
OSType: linux
Architecture: x86_64
CPUs: 10
Total Memory: 2GiB
Name: <machine_name_redacted>
ID: 917bfba6-6391-4968-855e-d48cc98a2ce2
Docker Root Dir: /var/lib/docker
Debug Mode: false
Experimental: false
Insecure Registries:
Live Restore Enabled: false

I hope that provides useful information.

Perfeito, Bernd Ziegenhagen. Parabéns...

É isso mesmo, Bug ao usar CT com ZFS
Share this answer
i found the bug. Using the ct in Proxmox with ZFS generate the problem. Move the ct in local storage (not ZFS) and all is fine :-)

Share this answer
AlexanderPlaza 26-May-23 11:38am    
I wouldn't say that's a useful solution as ZFS is much better then using a "local storage" which might be just ext4 and would have a single point of failure (the storage device)
PIEBALDconsult 26-Jul-23 23:46pm    
Please don't try to answer your own question, just use the Improve question button.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900