Click here to Skip to main content
15,746,202 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
how do I fix a terminal that does not import db when I enter: 'from app import db'?

PS C:\Flask-Website> & c:/Flask-Website/.venv/Scripts/Activate.ps1
(.venv) PS C:\Flask-Website> python
Python 3.11.2 (tags/v3.11.2:878ead1, Feb 7 2023, 16:38:35) [MSC v.1934 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> from app import db

What I have tried:

I have not really tried anything meaningful. I am a newbie programmer.
Updated 8-Mar-23 8:51am
Richard MacCutchan 8-Mar-23 6:06am    
I can only assume that there is no module named in the current directory. Please use the Improve question link above, and add complete details of what is not working.
Richard MacCutchan 8-Mar-23 12:10pm    
You have updated your question but there is still no useful information in it. Please do what I suggested above.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900