Click here to Skip to main content
15,936,602 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have installed the CodeProject AI Server on a Windows 10 PC and intend to use it with the Blue Iris Video Security program, but the CodeProject AI Server service will not start. The Windows system event log showed the error below...

The CodeProject.AI Server service failed to start due to the following error:
CodeProject.AI Server is not a valid Win32 application.

When I try to manually start the CodeProject AI Server service, I get the following error:

Windows could not start the CodeProject AI Server service on the Local Computer.
Error 193: 0xc1

What I have tried:

I have tried the usual: Restarting the computer, repairing the CodeProject AI installation, uninstalling and reinstalling Codeproject AI.
Posted
Updated 4-Jul-22 3:05am
Comments
Matthew Dennis 30-Jun-22 21:33pm    
CodeProject.AI Server is a 64 bit application.
Could you provide details of your system?

Do you have both 32 and 64 bit dotnet installed on your system, and which is first in your path?
Member 15692979 30-Jun-22 22:02pm    
Thanks for the questions.

My OS is Windows 10 Home and it is a 64-bit operating system, x64-based processor.

I guess I'm not exactly sure how to identify 32 vs 64 bit dotnets. Some of the dotnets installed on the system are followed by (x86) and some are (x64). Both were installed by the CodeProject AI installer.

I'm not sure how to determine which come first in my path. Not really sure which path you mean.
[no name] 1-Jul-22 10:16am    
For what it's worth:

https://bobcares.com/blog/error-193-0xc1-service-fails-to-start/

1 solution

I fixed the problem by opening the registry editor and navigating to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CodeProject.AI Server

I modified the ImagePath by adding quotes to the string. Specifically, I changed the ImagePath from this

C:\Program Files\CodeProject\AI\Server\CodeProject.AI.Server.exe

to this

"C:\Program Files\CodeProject\AI\Server\CodeProject.AI.Server.exe"

I think the problem was that the ImagePath includes a space. I think on some systems having a space in the ImagePath can create problems with starting the CodeProject.AI Server.
 
Share this answer
 
v4
Comments
Richard MacCutchan 4-Jul-22 11:04am    
That is a common issue in Windows when it tries to use a path that includes a space in a command window.
David Wilson from Unknown 21-Dec-23 14:50pm    
What if I don't have that entry at all in my registry? Of course I have everything up to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services. I would assume this means the installation is faulty or the zip file is corrupt. Using ... x64 2.3.4 Beta which is all I saw on the website

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900