Click here to Skip to main content
15,867,999 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Sample Input
3
6
-4 2 -1 8 4 5
8
-1 82 33 14 -5 60 79 84
5
-4 -7 8 4 -11

Sample Output
1
2
3

Output is a smallest order different value

What I have tried:

#include<stdio.h>

int main(){
int C;
int N;
int n;
scanf("%d", &C);
for(int i = 0; i < C;i++){
scanf("%d", &N);
for(int i = 0; i < N;i++){
scanf("%d", &n);
//
}
}




return 0;

}
Posted
Updated 18-Nov-21 22:26pm
Comments
Hansen 2021 19-Nov-21 2:14am    
how can I find the difference of the smallest order in value?

Firstly, there is no obvious connection between the input and the desired output - so go back to the original assignment, and read it carefully. Then try to process the input manually and generate the output - hwne you hav eit manually, it should be easier to automate it.

Secondly, while we are more than willing to help those that are stuck, that doesn't mean that we are here to do it all for you! We can't do all the work, you are either getting paid for this, or it's part of your grades and it wouldn't be at all fair for us to do it all for you.

So we need you to do the work, and we will help you when you get stuck. That doesn't mean we will give you a step by step solution you can hand in!
Start by explaining where you are at the moment, and what the next step in the process is. Then tell us what you have tried to get that next step working, and what happened when you did.

And all you have done so far is ... nothing at all that is related to the input and output you show.

If you are having problems getting started at all, then this may help: How to Write Code to Solve a Problem, A Beginner's Guide[^]
 
Share this answer
 
You best start with some Learn C tutorial to learn the basic. Pay attentation how to use the debugger.

Without the knowledge and skills to develop code you cant move on and will get a bad rating from your teacher.

tip: also search on Youtube for some tutorials
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900