Click here to Skip to main content
15,670,442 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more: , +
I'm working on a project that has to deliver reports in English and German languages. The English version works fine locally on my machine and also fine on the website. The German version works fine on my machine but not on the website: It gives the error
An error has occurred during report processing. Cannot create a connection to data source 'LRTmainDataSetD'. The type specified in the TypeName property of ObjectDataSource 'ObjectDataSource1' could not be found.
Both DataSets rely on the same connectionString. The code in XML for calling the DataSet is exactly the same. For the typeName property, please consult the following code:
<pre><asp:ObjectDataSource ID="ObjectDataSource1" runat="server" OldValuesParameterFormatString="original_{0}" SelectMethod="GetData" TypeName="LRT.LRTmainDataSetDTableAdapters.paGetUnameTableAdapter">
                        <asp:ControlParameter ControlID="tbUserName" Name="UserName" PropertyName="Text" Type="String" />
I'm lost for a solution.
Thanks for your help!

What I have tried:

I've re-created the Report and the DataSet in another VS 2019 IDE on a VPS. Then I copied it to my machine and ran it successfully. I scanned the functions in the respective .rdlc file and DataSets and found they follow the same pattern.
Updated 24-Aug-21 19:54pm
Richard Deeming 24-Aug-21 6:32am    
There's a secret error somewhere in your secret code. You should fix that.

Seriously, how do you expect anyone to help you fix your code when we can't see your code?

Click the green "Improve question" link and update your question to include the relevant parts of your code, and the full details of any errors.
swissfritz 24-Aug-21 21:42pm    
Thanks Richard, you're certainly right. I have customErrors Mode="off" and compilation debug="true" in my web.config. But the application doesn't throw any error. The error only shows on the reportViewer form, i.e. when the process is at its end. So I have no idea what "the relevant code" could be.

Are you using the english data-names in the german version?
Share this answer
swissfritz 24-Aug-21 21:14pm    
Thanks A! No, I use separate names for the stored procedures in the German version.
Richard's and A.Lefever's answers have pushed me in the right direction, thanks a lot!
If the English version works and the German one doesn't, there must be some error in the remote DB. So I tested the first 20 of the 33 stored procedures and voilà: There were no data from the selected user at all in one table on the website SQL Server. Now, I finally have something to debug :).
Share this answer
swissfritz 24-Aug-21 23:13pm    
Unfortunately, this didn't solve the problem. I fixed the procedure that loads the table but the reportViewer still shows the same error. Any more ideas from you?
Share this answer
swissfritz 25-Aug-21 2:42am    
Thanks A Lefever. This is not the way I do my quite complex reports. I use 33 Stored Procedures mixed with text. The mentioned example uses only Tables.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900