Click here to Skip to main content
15,665,276 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
we are creating a small app. When we try, form XCode, to run it, build it or archive it, the system creates this error: 

*error: '/Users/ujilapapuj/Documents/App/myQuantika-dtdulaakzqdzarbbvsimhukbhwem/Build/Products/Debug-iphoneos/' is longer than filepath buffer size (1025). (in target 'myQuantika' from project 'myQuantika')*

Now, all these subfolders have been created while compiling the project. We tried to shorten the root folder on which XCode compiles everything, but with no results. The system simply creates more subfolders until it reached the limits.

Everything else in the code works fine: no other warnings or errors. 

What do you think is causing this issue? Me and my collegues have been working on these for days with no results. 

(OSX and XCode are the latest versions).

Thank you for any help you can give :)

What I have tried:

Reinstall XCode and all the libraries. Change paths. Tried on another Mac.
Richard MacCutchan 3-May-21 12:18pm    
It looks like something has got a recursive list and is repeatedly adding the same folder to a path. Take a look at Xcode 3.2.5 error with argument list too long - iPhone project | OOPS TECH BLOG[^]

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900