Click here to Skip to main content
15,745,764 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have built mfc application on VS 6. It works fine on computers who have MS Office on them but when I run it on computers which doesn't have MS Office it shows some graphics glitch. For example some buttons and images wont appear on my application. I guess it have to do something with Active X controls.

What I have tried:

I did some research on internet and I found out it has do do something with controls.
For example:
CONTROL "",CH8_LABEL,"{978C9E23-D4B011CEBF2D00AA003F40D0}",0x0,16,161,8,15

this is code from my resource (.rc) file for a label.This control: 978C9E23D4B011CEBF2D00AA003F40D0 is missing from the regedit.exe
Updated 25-Dec-19 19:52pm

1 solution

Most probably, your VS6 application depends on MS Office ActiveX component for their functionality. You can just delete the activeX control from resource designer and *.tlh file from the project folder but then your code that talks to activeX will fail to compile.
Share this answer
Member 14630688 26-Dec-19 5:50am    
What if I install VS 6 on a pc which doesn't have MS office on it and build the code?
Shao Voon Wong 26-Dec-19 6:02am    
It still needs MS Office when it runs.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900