Click here to Skip to main content
15,662,478 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
When We are trying to load the XML file into oracle table we are getting the below error.
ORA-31061: XDB error: XML event error
ORA-19202: Error occurred in XML processing
In line 1 of orastream:
LPX-00210: expected '<' instead of '¿'

Any help much appreciated

What I have tried:

We’ve tried using sqlloader batch script to load the file into table
phil.o 14-Feb-18 7:11am    
You seem to have an encoding problem: check which encodings are supported by your XML-loading function, and provide it with an XML file which has the correct encoding.
Member 13638770 14-Feb-18 7:53am    
Thanks @phil.0 this is the batch script which im using to load the XML file
echo start/W sqlldr EKB/EKB@EKBPT CONTROL=%CTRLFILE%, LOG="%BATCH_LOG%\editrack_LOG\sqlldr_%YYYYMMDD%%HHMM%.txt",DATA="%FILE%%FileName%",skip=0,errors=0>> %LOG_FILE%
start /w sqlldr EKB/EKB@EKBPT CONTROL=%CTRLFILE%, LOG="%BATCH_LOG%\editrack_LOG\sqlldr_%YYYYMMDD%%HHMM%.txt",DATA="%FILE%%FileName%",skip=0,errors=1,load=1
phil.o 14-Feb-18 7:57am    
As I said, check which encoding the XML file currently has. Popular text editors, like Notepad++ for example, allow you to check which encoding a specific file is written with.
Member 13638770 14-Feb-18 7:58am    
As the file is 550MB we're not able to open it in Notepad++. As per my knowledge encoding of the file has Binary mode
Member 13638770 14-Feb-18 8:12am    
UTF-8 is the encoding type of my XML. How could i verify whether it will be supported by my xml-loading function?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900