Click here to Skip to main content
15,665,718 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
i am facing a problem . i am getting an error in my project suddenly i.e. -
the process cannot access the file ..\SchemaData\XSDContent-SendSchema.xsd.xml because it is being used by another process

and coming a lot of time when i am trying to do any thing on my project . also when i tried to generate receive schema instance it will showing successfully instance generation message but instance file not found .
i have googled so much but got nothing. i m new to biztalk. any help will be appreciat . thankx.

What I have tried:

i have also tried by creating a new project .but facing same problem
Updated 10-Jul-17 21:45pm

1 solution

Start by checking your own code: the message is saying that the file is in use - that could be by an external application, but it's pretty often the same app that gets the error, if care isn't taken when writing the software.

If you app opens the file and doesn't close and dispose it properly, then the file remains open until the Garbage Collector is started and gets rid of the objects holding the file for you - this may take minutes, hours, or weeks depending on how much memory your app uses!
So start with your code, and find everywhere you do anything with the file: check that your streams are all Closed and Disposed correctly when you are finished with them.
Share this answer
Gaurav Dixit 11-Jul-17 3:57am    
thanx dude, but it's happening with all my projects of biztalk . i have tried by opening some old project same problem occour in that too. now recently i have created a new project for test purpose , but facing same problem .i am trying to check where my process is using currently but no sign in task manager too ... any suggestion

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900