Click here to Skip to main content
15,665,942 members
Please Sign up or sign in to vote.
1.00/5 (2 votes)
See more: , +
At the first deploy the app is installed on my device and everything works well, but when I try to deploy the second time I get this error:
1>Deployment of application to device failed.
1>Error writing file '%FOLDERID_APPID_INSTALL%\{5ea233c7-23db-4a36-b02b-2554d58aba56}\resources.pri'. Error 0x80070005: Access is denied.
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

I tried to look after this issue, but I can't find the solution for my problem with that "resources.pri".
Someone know how can I resolve this problem?

What I have tried:

I tried to look after my problem and to check microsoft community and I can't find an answer.
Updated 25-Sep-16 20:46pm
ZurdoDev 20-Sep-16 7:16am    
Access is denied generally means a permissions issue.
Ionascut Mihai 20-Sep-16 7:21am    
There is no permission issue because the app runs at the first debuggind when I install it, but at the second debugging I get this error.
David_Wimbley 20-Sep-16 9:51am    
Saying there is no permission issue won't make the obvious permission issue your application is having, based on error message provided, go away.

What is likely happening is that something still has a lock on resources.pri and so access is denied. Without knowing a thing about your app or code base, look to see if you aren't freeing resources or something.
Ionascut Mihai 20-Sep-16 14:05pm    
I think that the problem is not in my application because a simple "Hello world" app is getting the same error at the second deploying. And to solve this problem I found that I need to uninstall the app and to deploy it again, but at the next deploying it has the same issue. I think that is a solution for this problem because I don't want to reins=tall my app at every two deployments.
David_Wimbley 20-Sep-16 14:54pm    
Uninstalling and reinstalling is a work around. That is not the solution. Again, Access denied is a permissions issue. That can be caused by an application maintaining a lock on a file when it should have released that lock or im sure many other things.

Your application is the issue. I highly doubt that you've stumbled across a bug in windows phone 8 OS that is as simple as resources not being freed...but hey, what do i know. If you have send it to Microsoft and see if you get some money. But it seems your not willing to debug your own code or admit that your code is the problem so I don't think anyone is going to be able to help you here.

1 solution

The most common reason of that error is that that currently logged user has not enough priviledges to run/deploy application.

Try to run Visual Studio in admin mode (right click -> run as admin).

Some people have reported that was installing issue. Re-installing VS and Phone SDK may resolve your issue: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) in Windows Phone SDK 8.0[^]
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900